Upgrade to Asterisk 1.8 using YUM

Now that Asterisk 1.8 has been released.

If you are more familiar in installing Asterisk (RPM packages) with YUM than compiling it from sources, you should try this process to upgrade to Asterisk 1.8 from your existing Asterisk 1.6 or even 1.4 installation.

As you know, Asterisk 1.6 RPM packages in asterisk.org repository are named asterisk16 while the new ones are named asterisk18. The upgrade isn’t as easy as a `yum update`, but it’s not too difficult.

From a Linux command line, run:
# yum shell

This enters the shell mode of yum. Once in the shell, enter the following.
# remove asterisk16 asterisk16-core
# install asterisk18-core asterisk18
# ts solve
# ts run

At this point, the package list will be calculated, and you should be presented with the option to finish the transaction. If everything looks correct, hit ‘Y’ and let it complete. You can then ‘exit’ the shell mode. Congratulations! You’ve just successfully installed Asterisk 1.8.

Note: If you’ve installed them, you may see asterisk16-addons or asterisk16-<insert module name> packages being removed. You can add the asterisk18 equivalents to the ‘install’ command above, and they will also be upgraded.

Note 2: To get FreePBX to support Asterisk 1.8, you’ll need to install freepbx-2.7.0-7 at a minimum. The easiest way to get this, is to `yum update` before running the above.

Coach outlet